re = /^(([1-9]\d*(\,\d+)*(\.\d{1,4})?)|(0\.\d{1,4})|0)$/m
str = '2,000,000
200000.0000
200
200.00000
2,000.00
1000,000
1,000000
2,000,000
200000.0000
200
200.00000
2,000.00
2,0,00.00
1,234,456.7890
0900
0.88
0
890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end