using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w-]+)=((['""]).*?\3)";
string input = @"x-x=""11111"" y-y=""John-Doe 23"" db {rty='Y453'} code {codeDate='2000-03-01T00:00:00'}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}