$re = '/([\w-]+)=(([\'"]).*?\3)/';
$str = 'x-x="11111" y-y="John-Doe 23" db {rty=\'Y453\'} code {codeDate=\'2000-03-01T00:00:00\'}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);