re = /([\w-]+)=((['"]).*?\3)/
str = 'x-x="11111" y-y="John-Doe 23" db {rty=\'Y453\'} code {codeDate=\'2000-03-01T00:00:00\'}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end