#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(= new ReportViewModel\d+)\((id)\)"
Local $sString = "= new ReportViewModel83(id)" & @CRLF & _
"= new ReportViewModel8(id)" & @CRLF & _
"= new ReportViewModel111(id)" & @CRLF & _
"= new ReportViewModel20()" & @CRLF & _
"= new ReportViewModel1(null)"
Local $sSubst = "$1($2,_ModelParam.Id)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)