using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(= new ReportViewModel\d+)\((id)\)";
string substitution = @"$1($2,_ModelParam.Id)";
string input = @"= new ReportViewModel83(id)
= new ReportViewModel8(id)
= new ReportViewModel111(id)
= new ReportViewModel20()
= new ReportViewModel1(null)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}