import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(= new ReportViewModel\\d+)\\((id)\\)";
final String string = "= new ReportViewModel83(id)\n"
+ "= new ReportViewModel8(id)\n"
+ "= new ReportViewModel111(id)\n"
+ "= new ReportViewModel20()\n"
+ "= new ReportViewModel1(null)";
final String subst = "$1($2,_ModelParam.Id)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}