package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)city[^0-9]*([0-9]+)`)
var str = `city7900/
cityid=7900
city7900-t40094705.nb1/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}