re = /city[^0-9]*([0-9]+)/m
str = 'city7900/
cityid=7900
city7900-t40094705.nb1/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end