$re = '/city[^0-9]*([0-9]+)/m';
$str = 'city7900/
cityid=7900
city7900-t40094705.nb1/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);