# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^ *-? +)?((\d+ +cases?)|(Product\w+)|(\d{4})|(\$[\d,.]+)|(Warehouse +\w+)|(-[^-\n]+(?:-|$)))(?: +(?:of|at|in) +| +)?/\1\t/gm;t' <<< " - 1 case of ProductA 2020 at $123,456.00 in Warehouse A
- 2 cases of ProductB 2025 at $123,456.00 in Warehouse B - optional remark"