# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^ *-? +)?((\d+ +cases?)|(Product\w+)|(\d{4})|(\$[\d,.]+)|(Warehouse +\w+)|(-[^-\n]+(?:-|$)))(?: +(?:of|at|in) +| +)?"
test_str = (" - 1 case of ProductA 2020 at $123,456.00 in Warehouse A\n"
" - 2 cases of ProductB 2025 at $123,456.00 in Warehouse B - optional remark")
subst = "\\1\\t"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.