use strict;
my $str = ' - 1 case of ProductA 2020 at $123,456.00 in Warehouse A
- 2 cases of ProductB 2025 at $123,456.00 in Warehouse B - optional remark';
my $regex = qr/(?:^ *-? +)?((\d+ +cases?)|(Product\w+)|(\d{4})|(\$[\d,.]+)|(Warehouse +\w+)|(-[^-\n]+(?:-|$)))(?: +(?:of|at|in) +| +)?/mp;
my $subst = '\\1\\t';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";