#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^ *-? +)?((\d+ +cases?)|(Product\w+)|(\d{4})|(\$[\d,.]+)|(Warehouse +\w+)|(-[^-\n]+(?:-|$)))(?: +(?:of|at|in) +| +)?"
Local $sString = " - 1 case of ProductA 2020 at $123,456.00 in Warehouse A" & @CRLF & _
" - 2 cases of ProductB 2025 at $123,456.00 in Warehouse B - optional remark"
Local $sSubst = "\1\t"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)