#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[/+ #_;.-]?(?<![0-9])[0-9]{9,10}(?![0-9])"
Local $sString = "12" & @CRLF & _
"123456789" & @CRLF & _
"1234567890" & @CRLF & _
"123456789/1234567890" & @CRLF & _
"123456789/1/123456789" & @CRLF & _
"123456789+1234567890" & @CRLF & _
"Order number: 6508955960_000010_1005500" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")