import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[/+ #_;.-]?(?<![0-9])[0-9]{9,10}(?![0-9])";
final String string = "12\n"
+ "123456789\n"
+ "1234567890\n"
+ "123456789/1234567890\n"
+ "123456789/1/123456789\n"
+ "123456789+1234567890\n"
+ "Order number: 6508955960_000010_1005500\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}