import re
regex = re.compile(r"[/+ #_;.-]?(?<![0-9])[0-9]{9,10}(?![0-9])", flags=re.MULTILINE)
test_str = ("12\n"
"123456789\n"
"1234567890\n"
"123456789/1234567890\n"
"123456789/1/123456789\n"
"123456789+1234567890\n"
"Order number: 6508955960_000010_1005500\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")