re = /[\/+ #_;.-]?(?<![0-9])[0-9]{9,10}(?![0-9])/m
str = '12
123456789
1234567890
123456789/1234567890
123456789/1/123456789
123456789+1234567890
Order number: 6508955960_000010_1005500
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end