#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(<p>)((?!<\/p>).)*?(<p>).*?(<\/p>)"
Local $sString = "<html><body><tile> <table><tbody><tr><td><p>Lorem Ipsum is simply dummy text of the printing and typesetting industry.</p></td><td><p>Lorem Ipsum is simply dummy text of the printing and typesetting industry.</p></td></tr></tbody></table><p>Hello there <p>Some Content </p>outer content <p>Some More content</p>hello</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")