use strict;
my $str = '<html><body><tile> <table><tbody><tr><td><p>Lorem Ipsum is simply dummy text of the printing and typesetting industry.</p></td><td><p>Lorem Ipsum is simply dummy text of the printing and typesetting industry.</p></td></tr></tbody></table><p>Hello there <p>Some Content </p>outer content <p>Some More content</p>hello</p>';
my $regex = qr/(<p>)((?!<\/p>).)*?(<p>).*?(<\/p>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}