$re = '/(<p>)((?!<\/p>).)*?(<p>).*?(<\/p>)/';
$str = '<html><body><tile> <table><tbody><tr><td><p>Lorem Ipsum is simply dummy text of the printing and typesetting industry.</p></td><td><p>Lorem Ipsum is simply dummy text of the printing and typesetting industry.</p></td></tr></tbody></table><p>Hello there <p>Some Content </p>outer content <p>Some More content</p>hello</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);