# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<p>)((?!<\/p>).)*?(<p>).*?(<\/p>)"
test_str = "<html><body><tile> <table><tbody><tr><td><p>Lorem Ipsum is simply dummy text of the printing and typesetting industry.</p></td><td><p>Lorem Ipsum is simply dummy text of the printing and typesetting industry.</p></td></tr></tbody></table><p>Hello there <p>Some Content </p>outer content <p>Some More content</p>hello</p>"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.