# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*<p>)(((?!<\\/p>).)*?)(<p>)(.*?)(<\\/p>)(.*)/\1\2\5\7/g;t' <<< "<html><body><tile> <table><tbody><tr><td><p>Lorem Ipsum is simply dummy text of the printing and typesetting industry.</p></td><td><p>Lorem Ipsum is simply dummy text of the printing and typesetting industry.</p></td></tr></tbody></table><p>Hello there <p>Some Content </p>outer content <p>Some More content</p>hello</p>"