using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*<p>)(((?!<\/p>).)*?)(<p>)(.*?)(<\/p>)(.*)";
string substitution = @"\1\2\5\7";
string input = @"<html><body><tile> <table><tbody><tr><td><p>Lorem Ipsum is simply dummy text of the printing and typesetting industry.</p></td><td><p>Lorem Ipsum is simply dummy text of the printing and typesetting industry.</p></td></tr></tbody></table><p>Hello there <p>Some Content </p>outer content <p>Some More content</p>hello</p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}