$re = '/(.*<p>)(((?!<\/p>).)*?)(<p>)(.*?)(<\/p>)(.*)/';
$str = '<html><body><tile> <table><tbody><tr><td><p>Lorem Ipsum is simply dummy text of the printing and typesetting industry.</p></td><td><p>Lorem Ipsum is simply dummy text of the printing and typesetting industry.</p></td></tr></tbody></table><p>Hello there <p>Some Content </p>outer content <p>Some More content</p>hello</p>';
$subst = "\1\2\5\7";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;