use strict;
my $str = '<html><body><tile> <table><tbody><tr><td><p>Lorem Ipsum is simply dummy text of the printing and typesetting industry.</p></td><td><p>Lorem Ipsum is simply dummy text of the printing and typesetting industry.</p></td></tr></tbody></table><p>Hello there <p>Some Content </p>outer content <p>Some More content</p>hello</p>';
my $regex = qr/(.*<p>)(((?!<\/p>).)*?)(<p>)(.*?)(<\/p>)(.*)/p;
my $subst = '\\1\\2\\5\\7';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";