import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^ \\t]+:)[\\s\\S]+?(?=^\\1|\\z)";
final String string = "Name: vm346\n"
+ " cpu 1 (12%) 6150m (76%)\n"
+ " memory 1130Mi (7%) 1130Mi (7%)\n"
+ "Name: vm847\n"
+ " cpu 6 (75%) 30150m (376%)\n"
+ " memory 12980Mi (87%) 12980Mi (87%)\n"
+ "Name: vm848\n"
+ " cpu 3500m (43%) 17150m (214%)\n"
+ " memory 6216Mi (41%) 6216Mi (41%)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}