re = /^([^ \t]+:)[\s\S]+?(?=^\1|\z)/m
str = 'Name: vm346
cpu 1 (12%) 6150m (76%)
memory 1130Mi (7%) 1130Mi (7%)
Name: vm847
cpu 6 (75%) 30150m (376%)
memory 12980Mi (87%) 12980Mi (87%)
Name: vm848
cpu 3500m (43%) 17150m (214%)
memory 6216Mi (41%) 6216Mi (41%)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end