package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(DEFI?)*\s?[A-Z]([A-Z]|[0-9]){0,4}=(([A-Z]([A-Z]|[0-9]){0,4})|([0-9]+(\.[0-9]+)?))\s?(DEFI?)*$`)
var str = `S=20845.2518 DEFI`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}