import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(DEFI?)*\\s?[A-Z]([A-Z]|[0-9]){0,4}=(([A-Z]([A-Z]|[0-9]){0,4})|([0-9]+(\\.[0-9]+)?))\\s?(DEFI?)*$";
final String string = "S=20845.2518 DEFI";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}