re = /^(DEFI?)*\s?[A-Z]([A-Z]|[0-9]){0,4}=(([A-Z]([A-Z]|[0-9]){0,4})|([0-9]+(\.[0-9]+)?))\s?(DEFI?)*$/
str = 'S=20845.2518 DEFI'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end