using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(feature|bug|bugfix|task|hotfix)\/[_\.A-Z+a-z\/0-9-]+$";
string input = @"feature/NSX-444_my-New-Feature";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}