re = /(feature|bug|bugfix|task|hotfix)\/[_\.A-Z+a-z\/0-9-]+$/m
str = 'feature/NSX-444_my-New-Feature'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end