// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(feature|bug|bugfix|task|hotfix)\/[_\.A-Z+a-z\/0-9-]+$").unwrap();
let string = "feature/NSX-444_my-New-Feature";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}