using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([|@\\]+)?([\w]+)";
string input = @"meaning
meaning|description
meaning@id
meaning|description@id
|description
|description@id
@id
meaning@id|description
sub1\|sub2
mea\|ning|descri\@ption
mea\@ning@id
meaning|description@identific\|\@ation";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}