import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([|@\\\\]+)?([\\w]+)";
final String string = "meaning\n"
+ "meaning|description\n"
+ "meaning@id\n"
+ "meaning|description@id\n"
+ "|description\n"
+ "|description@id\n"
+ "@id\n"
+ "meaning@id|description\n"
+ "sub1\\|sub2\n"
+ "mea\\|ning|descri\\@ption\n"
+ "mea\\@ning@id\n"
+ "meaning|description@identific\\|\\@ation";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}