package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([|@\\]+)?([\w]+)`)
var str = `meaning
meaning|description
meaning@id
meaning|description@id
|description
|description@id
@id
meaning@id|description
sub1\|sub2
mea\|ning|descri\@ption
mea\@ning@id
meaning|description@identific\|\@ation`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}