re = /([|@\\]+)?([\w]+)/m
str = 'meaning
meaning|description
meaning@id
meaning|description@id
|description
|description@id
@id
meaning@id|description
sub1\\|sub2
mea\\|ning|descri\\@ption
mea\\@ning@id
meaning|description@identific\\|\\@ation'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end