package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<ul) ?(([^>]*)class="([^"]*)"([^>]*))?`)
var str = `<ul id="test"class="children" data_test="equal"><li> test</li></ul>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}