const regex = /(<ul) ?(([^>]*)class="([^"]*)"([^>]*))?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<ul) ?(([^>]*)class="([^"]*)"([^>]*))?', '')
const str = `<ul id="test"class="children" data_test="equal"><li> test</li></ul>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}