$re = '/(<ul) ?(([^>]*)class="([^"]*)"([^>]*))?/';
$str = '<ul id="test"class="children" data_test="equal"><li> test</li></ul>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);