import Foundation
let pattern = #"(<ul) ?(([^>]*)class="([^"]*)"([^>]*))?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<ul id="test"class="children" data_test="equal"><li> test</li></ul>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}