# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n{2,}/\n/mg;t' <<< "Строка 1
Строка 2
Строка 3"