$re = '~\n{2,}~m';
$str = 'Строка 1
Строка 2
Строка 3';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;