import re
regex = re.compile(r"\n{2,}", flags=re.MULTILINE)
test_str = ("Строка 1\n"
"Строка 2\n\n"
"Строка 3")
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)