const regex = new RegExp('\\n{2,}', 'mg')
const str = `Строка 1
Строка 2
Строка 3`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);