using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"heading1\n(.*)\n{2}?";
string input = @"heading1
foo=bar
baz=qux
heading2
spam=ham
heading3
this=that";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}