const regex = new RegExp('heading1\\n(.*)\\n{2}?', 's')
const str = `heading1
foo=bar
baz=qux
heading2
spam=ham
heading3
this=that`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}