import re
regex = re.compile(r"heading1\n(.*)\n{2}?", flags=re.DOTALL)
test_str = ("heading1\n"
"foo=bar\n"
"baz=qux\n\n"
"heading2\n"
"spam=ham\n\n"
"heading3\n"
"this=that")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")