using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#(').*(')";
string input = @"#'The universe is big, it's vast and complicated, and ridiculous and sometimes, very rarely, impossible things just happen and we call them miracles.'
'I am and always will be the optimist. The hoper of far-flung hopes and the dreamer of improbable dreams.'
#'No, hold on. Sorry, that's the 'The Lion King'.'
#'What's the point in two hearts if you can't be a bit forgiving now and then?'
'You know that in 900 years in time and space I've never met anyone who wasn't important before.'
#'You want weapons? We're in a library! Books! Best weapons in the world!'";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}